Delayed completion of North Carolina searches
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Oct 22, 2024 - 17:42 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 22, 2024 - 03:13 UTC
Investigating
We are currently investigating this issue.
Posted Oct 22, 2024 - 03:01 UTC
This incident affected: Data Source.