MVR Screenings Are Delayed
Incident Report for Checkr
Resolved
We've resolved this issue.
Posted Aug 09, 2021 - 21:56 UTC
Monitoring
We have implemented a fix and are monitoring the recovery as of 14:12 PT.
Posted Aug 09, 2021 - 21:26 UTC
Investigating
As of 13:00 PT reports containing MVR (Motor Vehicle Records) screenings are delayed. We're working to identify the root cause and implement a solution! We'll provide an update shortly.
Posted Aug 09, 2021 - 20:52 UTC
This incident affected: Data Source.