Federal Criminal Screenings Are Delayed
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Mar 01, 2021 - 20:43 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2021 - 20:25 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 01, 2021 - 18:41 UTC
Identified
We have been made aware of a provider outage that is delaying the completion of Federal Criminal screenings. Screenings ordered after 6:30 AM PT today are currently impacted. We'll provide an update when the provider has resolved the issue!
Posted Mar 01, 2021 - 18:33 UTC
This incident affected: API, Client Dashboard, and Data Source.