Partial Service Outage
Incident Report for Checkr
Resolved
Applicants should be able to upload documents again. Emails are still delayed.
Posted 12 months ago. Dec 16, 2016 - 21:11 UTC
Identified
Applicants are currently unable to upload documents. Emails are also delayed. The issue is identified and we'll update when resolved.
Posted 12 months ago. Dec 16, 2016 - 20:57 UTC