Dashboard degraded performance
Incident Report for Checkr
Resolved
This incident is resolved and the Dashboard is fully operational.
Posted about 1 year ago. Oct 18, 2016 - 20:05 UTC
Investigating
We are investigating problems working with the dashboard.
Posted about 1 year ago. Oct 18, 2016 - 19:54 UTC