Reports completion delays
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 28, 2018 - 00:18 UTC
Monitoring
We are currently processing the backlog of Reports and monitoring.
Posted 9 months ago. Mar 27, 2018 - 23:52 UTC
Investigating
We are currently experiencing delays processing Reports. This shouldn't impact access to the dashboard nor API availability.
Posted 9 months ago. Mar 27, 2018 - 22:18 UTC