Degraded API & dashboard Performance
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted 9 months ago. Mar 17, 2017 - 19:24 UTC
Monitoring
Latency seems now back to normal.
Posted 9 months ago. Mar 17, 2017 - 19:19 UTC
Investigating
We are currently experiencing high latency on our API and dashboard.
Posted 9 months ago. Mar 17, 2017 - 19:16 UTC