API and Dashboard errors
Incident Report for Checkr
Resolved
All systems are back to normal.
Posted about 1 year ago. Nov 01, 2017 - 20:37 UTC
Investigating
Our systems are returning errors for many operations. Engineers are investigating.
Posted about 1 year ago. Nov 01, 2017 - 20:20 UTC