Delays in Reports completion
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted 10 months ago. Mar 04, 2017 - 01:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 10 months ago. Mar 04, 2017 - 01:07 UTC
Investigating
Since 10:00am we are experiencing intermittent issues with our queueing system, causing delays for some Report completion.
Posted 10 months ago. Mar 03, 2017 - 22:10 UTC