Report processing delays
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 13, 2018 - 19:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Aug 13, 2018 - 18:54 UTC
Investigating
We're currently investigating an issue causing delays in report processing.
Posted 4 months ago. Aug 13, 2018 - 18:34 UTC
This incident affected: API, Webhooks, and Dashboard.