MVR Delays
Incident Report for Checkr
Resolved
The issue is resolved and all Motor Vehicle Reports are now processing normally.
Posted about 1 month ago. Sep 16, 2017 - 16:26 UTC
Investigating
Some Motor Vehicle reports are experiencing longer than usual turnaround time. Engineers are investigating.
Posted about 1 month ago. Sep 16, 2017 - 14:50 UTC