Outage
Incident Report for Checkr
Resolved
This issue has been resolved.
Posted 12 months ago. Nov 01, 2016 - 19:37 UTC
Investigating
We are investigating a system outage and will update when more details are available.
Posted 12 months ago. Nov 01, 2016 - 19:32 UTC