Canadian dashboard issues
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted 28 days ago. Sep 20, 2017 - 01:34 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 29 days ago. Sep 19, 2017 - 22:23 UTC
Investigating
We are currently experiencing issues with our Canadian dashboard.
Posted 29 days ago. Sep 19, 2017 - 22:13 UTC