Issues loading some Reports on our dashboard
Incident Report for Checkr
Resolved
We have recovered from the outage. There may be some residual delays as we continue to process reports received during the outage.
Posted 8 months ago. Mar 01, 2017 - 02:34 UTC
Identified
Reports are now loading on the dashboard. Report completion is still delayed.
Posted 8 months ago. Feb 28, 2017 - 19:53 UTC
Investigating
Our cloud hosting provider is having issues with their storage service, resulting in timeouts when loading the Reports page and delays in Report completion.
Posted 8 months ago. Feb 28, 2017 - 17:53 UTC