Federal Criminal Searches Delayed for Maintenance
Incident Report for Checkr
Resolved
This incident has been resolved.
Posted Apr 14, 2024 - 23:56 UTC
Identified
One of our Vendors is undergoing maintenance which will delay reports with Federal searches
Posted Apr 14, 2024 - 15:05 UTC
This incident affected: Data Source.