Intermittent issues loading Applicant Portal and Verifications
Incident Report for Checkr
Resolved
From 15:33–17:03 UTC we saw elevated latency loading Applicant Portal and Verifications. The issue has been resolved.
Posted 10 months ago. Jan 01, 2017 - 01:23 UTC
Investigating
We're seeing intermittent issues loading Applicant Portal and Verifications.
Posted 10 months ago. Jan 01, 2017 - 01:01 UTC