Reports delayed
Incident Report for Checkr
Resolved
All reports are now processing normally.
Posted about 1 year ago. Sep 16, 2016 - 20:09 UTC
Identified
Reports submitted between about 2am and 8:15am Pacific will have their processing delayed. Reports submitted outside of this time window are processing normally.
Posted about 1 year ago. Sep 16, 2016 - 16:52 UTC